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Exercises 5a - 5d overview

These exercises will demonstrate an approach for developing applications by using principles
from agile development and using DevOps processes and tooling.

You'll develop a REST API that will calculate the FizzBuzz result for a given range.

FizzBuzz is a children's numeracy game where any number divisible by 3 is replaced by the
word Fizz, any number divisible by 5 is replaced with the word Buzz, and any number divisible
by both 3 and 5 is replaced with the word FizzBuzz.

For example, for the range 1 .. 20, the response is:

1, 2, ¥Fizz, 4, Buzz, ¥Fizz, 7, 8, F¥Fizz, Buzz, 11, Fizz, 13, 14,
FizzBuzz, 1lo6, 17, Fizz, 19, Buzz

You will use Node.js as the runtime and use test-driven development practices to create the
solution.
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Creating the project source code repository

Before you write any code, you must have the correct tooling and a source code repository. For
this exercise, you'll use the Git service from IBM DevOps Services for Bluemix.

1. Log in to DevOps Services for Bluemix: http://hub.jazz.net.

IBM Bluemix DevOps Services

DevOps Made Easy

Integrated Agile Planning, Coding, Building, Deploying

Sign up for free

2. From your MyProjects page, click CREATE PROJECT.

|IBM Bluemix DevOps Services MY PROJECTS

PROJECTS

Your project has been successfully deleted

binnes | bi-NRcustom

3. Create a Git repository on Bluemix:
a. Enter a project name.
b. Create a new repository.
c. Create a Git repo on Bluemix.
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Create a project

binnes |

Create a new repository or link to an existing one @

&

Link to an existing repository

Create a new repository

Choose your new repository location @

Create a Git repo on GitHub Create Jazz SCM on Bluemix

Create a Git repo on Bluemix

https://hub.jazz.net/git/binnes/fizzbuzz-w3

4. Initialize the repository.

Initialize repository contents

v Initialize the repository with a README and license template.

Getting Started with IBM Bluemix

If you want to share your project and make it searchable to the public, do not select the

Private Project checkbox.

Scrum development.

If you want to use the Track and Plan tool to support agile methodology, add features for

Select the checkbox to make the project a Bluemix project. Then, provide the details of

the Bluemix space that the application will be deployed to.
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Select project contents

[+ Private Project

Private projects are only accessible by invited team members. Learn more

[ Add features for Scrum development (This option can only be added at project creation time.)

Select this if you're familiar with Serum and plan to deliver software on regular sprints. @

@ak& this a Bluemix Project
elect this if you want to deploy your application to the IBM Bluemix cloud platform. Find out how &

Bluemix projects are charged for Track & Plan and Delivery Pipeline (Build & Deploy) usage in accerdance with the
Bluemix pricing plan.

Select a Bluemix space to bt B Your project must be connected to a Bluemix space for
billing purposes. Normally you should select the "dev"
Region (Development) space you want to use with this
application.
Organization ) . .
If you prefer to do this later just uncheck "Make this a
Space Bluemix Project" to continue.

These selections can be changesater in the opti
your Project Settings.

Under the Standard plan, Track and Plan is free for 3 users. Delivery Pipeline offers 60 minutes of build time and 2
deployers per month for free. To continue using these services beyond the free tier, you must add one or both of the
Track and Plan and Delivery Pipeline (Build & Deploy) services to the space you have configured for billing. Learn more.

After you've added either of these services to your billing space, you can monitor usage in the Bluemix Account usage
page.

7. Click CREATE to create the project.

The code repository has been created, and you can create a new Eclipse project that is
based on the repository.

8. In the DevOps Services console, select the Git URL link and copy the URL. Use Ctrl+C
orCmd C.

fizzbuzz-w3

Owner:

Branch: master v 4,

Copy the Git URL
binnes | fizbuzz-wa hitps:/ihub jazz. netigittbinnes/izzbuzz-wa
Last commit by Git @ IBM Bluemix DevOps Services=nuursayw
Initial commit

9. Start Eclipse and then from the main menu, click File > Import.

10.From the Select dialog, click Git > Project from Git and then click Next.
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Select
Import cne or more projects from a Git Repository. ? - 5

Select an import source:

» (= General
¥ (= Android
P (2 C/C++
b (=CVS

b (=EJB

¥ (= Gi

BR Projects from Git
[y, ———
P (=-Java EE
¥ (= Maven
¥ (= Plug-in Development

» [~ Remote Systems
» (= Run/Debug

P (= Tasks

¥ (= Team

> (= Tern

W (= Web

(@) | Next> | Gancel

11.In the Git dialog, select Clone URI and then click Next.

Select Repository Source

Select a location of Git Repositories

| ] Existing local repository
| Clone URI

@ L T Cangel

12.In the next dialog, paste the Git repository URL into the URI Location field. This will
automatically populate the Host and Repository path.

13. Enter your DevOps services user name and password. Optionally, select to store the Git
credentials in a secure store in Eclipse. You will need to provide additional information to
initialize the secure store if this is the first time that you store credentials.

14.Click Next.
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Source Git Repository

Enter the location of the source repository. “L |
-
Location
URI: 9 https:/hub jazz.net/git/binnes/fizzbuzz-w3 Local File,
Host: hub.jazz.net

Repository path: | /gitv'binnes/fizzbuzz-w3
Connection

Protocol: | hitps ||

Port:

Authentication

User: binnes@uk.ibm.com
Password: 000 sssssess

Store in Secure Stors

(‘?} < Back | Next> | Gancel

Eclipse will query the Git repository and list the next branch that’s available. Because you
just created the repository, only the master branch exists.

15. Leave the master branch selected and click Next.

Branch Selection

1
Select branches to clone from remote repositery. Remote tracking branches will m |
be created to track updates for these branches in the remote repository. A
Branches of https://hub.jazz. net/git/binnes/fizzbuzz-w3:
]
@  shmaster
Deselect All
@ <Back | QECIE | Cancel

The local destination is then chosen. The default location is <user home

directory>/git/<project name>. Use the suggested default location. If you want to
change it, you must remember the location because you will need it later in the exercise.

16. Click Next.
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Local Destination

Configure the local storage lecation for fizzbuzz-w3.

Destination
Directory: fUsers/binnes/gitfizzbuzz-w3

Initial branch: =~ master

Clone submodules

Configuration

Remote name: | origin

@ <sock | (RN

Getting Started with IBM Bluemix

Browse

%)

17.Select the wizard to import as a general project and then click Next.

Select a wizard to use for importing projects

Depending en the wizard, you may select a directory to determine the wizard's

scope

Wizard for project import

Impert existing Eclipse projects

Impert using the New Project wizard

@ Import as general project

(=~Working Directory - /Users/binnes/git/fizzbuzz-w3

@ <Back | QEUEIER

GIT|
W

-

18.In the Import Projects dialog, enter an Eclipse project name. You should use the same
name as the DevOps service project name, but you can change it if needed.

19.Click Finish.
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Import Projects

Gl
Impert projects from a Git repository i |
-
Project name | fizzbuzz-w3
Directory
('7:- < Back Cancel | Finish ]

You now have an Eclipse project linked to your DevOps services Git repository. To complete
the project setup, configure Eclipse to support JavaScript development.

20. Switch Eclipse to the JavaScript perspective:
a. Click Add Perspective at the top right of the Eclipse window.

:j B %@ Java EE | |
o= Outline 2 Task List =0 |

An outline is not available.

b. Select JavaScript from the list.

21.Enable the NodeJS facet on the project:
a. Right-click the project name and click Properties.

[2 Project Explorer 52 B & =
(% oo gy L
[ Licer
pymea  Golnto
Show In >
& Copy G0
Paste
% Delete ®
Remove from Context
Move...
Rename... P
£ Import...
£ Export...
&) Refresh F5
Close Project

Close Unrelated Projects

Validate

Show in Remote Systems view
Profile As

Debug As

Run As

Replace With

Restore from Local History...
V8 Debugging

StartExplorer

Team

Compare With

Configure

Source

YYYYYY YVYVYY

®

Properties

b. In the Project Facet dialog, click Project Facets and then click Convert to
faceted form.
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Q Project Facets Oy -

use project facets. Converting this project to faceted form wil allow you to
hnologies.

Revert Apply

c. When you see the list of facets, click Node.js Application. Click OK.

Adding the facet automatically creates a sample application in the project.
d. Remove the app.js and package. json files. Right-click each file, click Delete,
and confirm the deletion.
The project shows that there are changes to the local copy of the project. These are the

Eclipse project setting files. Don't save these as part of the source code.

22.Add a navigator view to see all the files in the project:
a. Click Window > Show View and then click Navigator.
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Minimize
E  Zoom VW_IICs/BlueMix/workshop V3/works
J Toggle Full Screen ~3F
New Window
Editor >
Hide Toolbar
Open Perspective »
Show View »> B Console X#Qc
Customize Perspective... Bl
Save Perspective As... @ BRI
Reset Perspective... Tg Hierarchy
Close Perspective . Mavigator
Close All Perspectives 5= Outline N#¥QO0
o [} Problems #Q X
Navigation »
=g Progress

Exercise 5a: Creating the project source code repo

Getting Started with IBM Bluemix

Bring Al to Front ¢
[?5 Project Explorer

f& Script Explorer

< Search X8QSs
= Tasks
Other... N¥QQ

b. Right-click the project name in the Navigator view and click New > File.

> fizzbuzz-wG i
» (3> settings

{# JavaScript Project

¥ .project Go Into 4 Project...
[EjLicensetx  Open in New Window
[+ README + 4§ JavaScript Source File
[ Copy 4 Folder
Paste [ File
* Delete [ Untitled Text File
Move..
Rename... 4 Example...
2 Import... [ Other... BN
£ Fxnort

c. Name the file .gitignore and then click Finish.

File

Create a new file resource.

Enter or select the parent folder:

fizzbuzz-w3

=
¥ (54> fizzbuzz-w@ [fizzbuzz-wa master]
(= RemoteSystemsTempFiles

File name: | .gitignore

Advanced >>

@ cancol | TN

d. Add the following two lines to the .gitignore file:

Windows: Leave the slash as specified; do not change itto .settings\:

.project
.settings/

The project still shows that there are changes. This occurs because the .gitignore file
is a new file that is not committed and pushed to the master branch on the Git server.
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23.Commit and push the .gitignore file:
a. Right-click the project name and click Team > Commit.

L Project Explorer - Mavigator &3 = o.g\(ignare b9
= <_5|) - 1 .project

? .settings/
= New >

P (= settil
© atia Go Into
¥ proje  Open in New Window

Licer
%REA[ & Copy
Paste
% Delete
Move...
Rename...

i Import...
g Export...

# Refresh
Close Project
Close Unrelated Projects

Validate

Show in Remote Systems view
Profile As

Debug As

Run As

Replace With

Restore from Local History...
V8 Debugging

StartExplorer

Team

Compare With

yvwyvwy

<] Commit... N3
Stashes >

'YRAY Y

b. In the Commit Changes dialog, enter a commit message and select the
.gitignore file. Then, click Commit and Push.

Commit Changes to Git Repository

Gl

Commit message 5 3 =
Yadding .gitignore file to project

Author. binnes <binnes@uk.ibm.com=

Committer: | binnes <binnes@uk.ibm.com:

Files (1/1) 2] | (]
Status Path

1\, .gitignore

Open Git Staging view Commit and Push Cangel | Commit ]

c. Close the confirmation dialog by clicking OK.
The project will no longer show that there are outstanding changes.

Finally, you should add a new window to access the command line. However, this is not
necessary. Instead, you can use a command window outside Eclipse, but it's more
convenient to have everything in Eclipse because it provides a better working
environment.
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24.Create a terminals view:
a. From the main menu, click Window > Show View and then click Other.

b.

C.

Help
Minimize "
Zoom ts/BlueMix/workshop V3/workspace
| Toggle Full Screen ~38F l
New Window
Editor >
Hide Toolbar
Open Perspective »>
Show View » & Console N®ac
Customize Perspective... & Declaration
Save Perspective As... [l socshaby
Reset Perspective... fs Hierarchy
Close Perspective . Navigator
Close All Perspectives 2= Qutline X#¥QO0
- [# Problems #QX
Navigation >
Bring Al to Front Sl
[#5 Project Explorer
[# Script Explorer
" Search \®QS
| Tasks
Other... T®QQ

Getting Started with IBM Bluemix

In the dialog, click Terminals > Terminals and then click OK.

P (= JavaServer Faces
P (= JPA

P (= Make

b = Markdown

F (= Maven

P (= Mylyn

b (= Plug-in Development
P (= Remote Systems
P (= REST Client

P (= Server

b (= Team

b (= Terminal

¥ (= Terminals

b (= Tracer for OpenGL ES
P (= Web Services

Cancel

In the Terminals window, drag the tab to split the bottom section of the screen to

allow concurrent viewing of the terminal and the problem views.

[£2 Problems @ Documentation [ Declaration

B Torminals 3

\

Drag and release
when window
outlines show 2

windows

If a command prompt isn’t shown, click the Open Terminal icon to start a new

terminal. Use the default setting. On some platforms, this happens automatically.
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- =

[0 Problems 2 Documentation [&, Declaration O & Teminals 52 ] = =0

Description ~ Resource Path
a = Brians-MacBook-Pro.local 3

bash-3.2%
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