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Working with Eclipse and Bluemix
This exercise shows you how to work with Eclipse and Bluemix.

1. Launch Eclipse and switch to the JavaScript perspective. You should use a new
workspace, but this is not essential.

Tt ::ﬁ;vﬁv%v:b Q”'vB:”ﬁﬁ’:E:E & ®m - - e | _@‘JavaScript

2. Configure Eclipse to use Bluemix as a server by opening Eclipse Preferences and
clicking Server > Runtime Environments.

type filter rext Server Runtime Environments v e w
¥ General 5 -
» Android Add, remove, or edit server runtime environments.

Ansi Console Server runtime environments

b Ant N ik 1 e
P Aptana Studio ;ma ype
» + [Zl Web Preview Server Runtime  Web Preview Server Runtime —
C/C+ a
P Cloud Foundry Edit...

Context-Aware Search
P Data Management
Dependency Build
EditBox
P Generic Service Client | Search... |
GFM Viewer I
Gradle{Enide)
» Help
P InstallfUpdate

Remove

| Columns... |

Instant Messaging
Flava
W Java EE
b Java Persistence
P JavaScript
JazzHub
P JSHint
P Maven
Maven(Enide)
» Mylyn
»Nodeclipse
Planning
#Plug-in Development
F PyDev
FRemote Systems
P Run/Debug
¥S5erver
Audic
Launching
Owverlays
Profile

Runtime Environments [

» Team
Team Build

P Team Process
Terminal
Validation

FWeb

= P
'\_?,‘ | Cancel | oK

3. Click Add. Then, select IBM Bluemix Runtime and select the Create a new local
server checkbox.
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New Server Runtime Environment D

Define a new server runtime environment

Download additional server adapters

Select the type of runtime environment:

type filter text
¥ = Apache
W (= Basic
¥ = 1BM
‘Web Preview Server Runtime

(&) WebSphere Application Server V8.5 Liberty Profile
P = )Boss
P = ObjectWeb
¥ (= Pivotal

IBM Bluemix supports Java EE modules, JavaScript modules and packaged servers of Liberty
Profile.

(@ Create a new local server,

Cancel | Finish

@ < Back Next >

4. Click Next.

5. Select the appropriate URL to match the region that you have been using.

IEM Bluemix Account na

(D Enter an email address /'

Email: |
Password:
URL: IBM Bluemix - https./fapi.ng.bluemix.net Manage Cloud...

Bluemix London - https://api.eu-gb.bluemix.net

IBM Staging - https://api.stagel.ng.bluemix.net
T g e

@ < Back Cancel

6. Enter your email and password, which are the credentials that you used to log into
Bluemix. Click Validate Account to ensure that all details are valid and then click Next.

7. Select the organization and space that you want to use and then click Finish. Click OK to
close the Preferences page.

If you want to work with multiple spaces in Eclipse, you must create multiple server
configurations.

8. Open the Servers view in Eclipse. If it's not showing, click Window > Show View >
Servers.
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*! Problems (@ Documentation [, Declaration i Servers &3 =1

 |BM Bluemix - binnes@uk.ibm.com - workshop - https://api.eu-gb.bluemix.net [Started, Synchronized]

Use the same application that you used in the last session. You should have the archive file
that you downloaded in the last exercise on your workstation. If not, deploy the Node.js
Cloudant Web Starter application from the Bluemix web Ul, click View Guide, and then
download the starter application.

9. Import the starter application package to Eclipse by clicking File > Import.

10.In the Import dialog, click General > Existing Projects into Workspace.

Select \
Create new projects from an archive file or directory. [E - 5 I

Select an import source:

type filter text

W [=-General
[T, Archive File
[3 Existing Folde
£ Existing Projects into Workspace
[:l
=l preferences
P = Android
P =C/CHt
P (=Cvs
> (=EB
P = Git
P = Git
P = Install
W = Java EE
W = Jazz Source Control
P = Maven
P [=- 0OSGi

® < Back [ Next > ] |  Cancel | Finish

11.Click Next. Then, select the downloaded Zip file and click Finish.
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Select root directory:

o Select archive file: /Users/binnes/work/Cloud/WW _IICs/Blue Mixl\l_“

Projects:

cloudant_beilerplate_nodejs {/)

Options
<
v

Hide projects that already exist in the workspace
Working sets

Add project to working sets

Working sets:

() = Back

The project will be created.

Before JavaScript applications can be deployed to Bluemix by the plug-in, those applications

Browse...

Select All

Deselect All

Refresh

Getting Started with IBM Bluemix

must be identified as a project suitable for Bluemix deployment by assigning a facet to the

project.

12.Right-click the project in the Project Explorer view and click Properties.

[ Projct Explorer 53
=54 -

cloudant_bolerplato.n S ,
Go Into
Show In Xa#w  »
Show In >
Show In >
[ Copy #C

Copy Qualified Name
[ Paste ®/Y
X Delete [
Remove from Context
Move..
Rename... F2

2 Import...
£ Export...

2] Refresh F5
Close Project
Close Unrelated Projects

Validate

Show in Remote Systems view
Run As

Debug As

Profile As.

Restore from Local History...
V8 Debugging

StartExplorer

Team

Compare With

Configure

Source

vvyyw

>
>
»
>
»
>

= Properties

13.Click Project Facets > Convert to faceted form.
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Project Facets l=1 - v
¥ Resource
Bullders This project is not configured to use project facets. Converting this
» JavaScript project to faceted form will allow you to easily control the available
> . technologies.
' __ Project Facets Convart to faceted form...
Run/Debug Settings
P Task Repositery
Task Tags
P Validation
WikiText
Revert Apply
@ canco | (TSN

14.When you see the facets, select the Node.js Application facet. Click OK to close the

dialog.

Project Facets =04 - -
Configuration: <gustom: a Save As... Delete
Project Facet .-'—— L0 Runtimes

|= Application Client module
b |5 Axis2 Web Services
= EL(D:Z Fo“:m:r; Stz.mdalone Application Enables the Node.js applicatic
El X Web Services i
3 Dynamic Web Module BY Bluemix
= EAR
(% EJB Module
|= EJBDoclet (XDoclet)
m Java
|= JavaScript
|= JavaServer Faces
|= JAX-RS (REST Web Services)
+ JAXB
|= JCA Module
<Hr JPA
) B Node.js Application
|= Static Web Module
|=| Utility Medule

UEI MNode.js Application 1.0

Revert Apply

Cancel | (LS

15.Delete the manifest.yml file by right-clicking it and clicking Delete.

16. Deploy the application. Right-click IBM Bluemix. If you have multiple definitions in the
Servers view, select the server definition for the space that you want to deploy the

application to.
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{2 Markers E Properties % Servers 53 8 Data s

& IBM Blu)

EBWED Pre

—

] work = B

5 it§

New »>

Open F3 |

Show In NEW >

= Copy #®C
Paste

¥ Delete =

Rename F2
Connect

-7 Disconnect

7 Restart in Debug {

2 Restart Y #R
Restart in Profile

Stop S

=L Publish ®P

Clean...

far Add and Remove...

Monitoring >

Clone Server...

Update Password

Properties 1

17.Click Add and Remove.

Getting Started with IBM Bluemix

18.Select the cloudant_boilerplate_nodejs in the Available column and click Add to move
it to the Configured column.

Move resources to the right to configure them on the server

Available:

<< Remove All

If server is started, publish changes immediately

19.Click Finish.

Configured:
l':}f cloudant_baollerplate_nodejs

20.In the Deploy dialog, change the application name to something unique. Click Next.
Ensure that the URL contains a string that will be unique and then click Next.

e
21.0n the Services selection window, click the Add a Service ( **) icon to add a service.
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8no Application |
Services selection Q An outline is not available. ::':ne:
Bind or add new services n%‘ art
art in
Select services to bind to the application: @ ish

Name A Vendor Provider Version Plan Tunnel A-cld a service to the server and automat-ica.llv

select it for the deployed application.
N BTy

fing

Erver.
Passv

1o Con

(‘:?:J < Back | | Nextx || Cancel | [ Finish ]

|

22.When the list of available services is shown, select the CloudantNoSQLDB service.

Available Services

Filter: gloudant e

cudantMeSQLDB
d Cloudant NeSOL DB provides access to a fully managed
NoSGQL JSON data layer that's always on. This service is
compatible with CouchDB, and accessible through a simple to
use HTTP interface for mobile...

MobileData

Enhance your mobile apps through simple to use SDKs to save
shared data in a scalable, managed database as a service.
Powered by Cloudant.

Clear Add ==

23.Click Finish and Finish again to close the application Deploy dialog.

The application is now being deployed to Bluemix. Eclipse should automatically switch to the
Console view where you see details of the deployment.
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17 Problems [ Console [ Properties | 414 Servers 53

V*IBM Bluemix - binnes@uk.ibm.com - workshop - https.//api.eu-gb.bluemix.net [Started, Synchronized]
New =
Start
Stop
“%, Restart
% Remove ®

Launch JavaScript Debugger
Show Recent Logs

Update and Restart

Push

Link with Project...

Unlink Proje

Open Home Page

Properties

24. After the application is running, switch to the Server view and expand the Bluemix
server. You should see the application in the list. Start the application from Eclipse by
right-clicking the application in the Servers view and clicking Open Home Page.

Tip: In Eclipse, you can change the browser that’s used to start applications by clicking
Window > Web Browser and selecting your preferred browser.

25.Remove the sample document from the database to allow the application to create it
when the database launches. In the Bluemix web Ul, select the Cloudant Service
instance and then launch the Cloudant Dashboard.

Cloudant NoSQL DB

You should see a single database:

Databases & AddNewDatabase = Gp APIURL

8 Your Databases
Name Size # of Docs Update Seq Actions

my_sample_db 89 bytes 1 1 E D

26.Select the database and then delete the document. Confirm the deletion.

Cancel © Upload Attachment = C' Clone Document ([l Delete

Delete

27.In a text editor, open the file app. js:
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L™ Project Explorer 2 [=l <§> ¥ =0

v '_,-'_;cloudant beilerplate_ncdejs
b =, JavaScript Resources
b =118n
b (= nede_modules
b = public

Eapp.js
Srtoterplate-log.log
@ instructions.md
"_@ package.json
README.md

28.Modify the name of the file, the file description and value (lines 306, 307, and 310) to
replace sample with test:

303 if(len == @) {

304 //push sample data

305 // save doc

306 var docName = doc”;

307 var docDesc = ‘ocument‘;
308 db.insert({

309 name : docName

31e value : ‘ocument‘

311 }, "', function(err, doc) {

29. Save the changes by clicking File > Save.

Notice in the Server view that the state of the Bluemix server has changed to republish,
which means that an application has changed. However, the application has not yet been
published to Bluemix.

30. Select the cloudant_boilerplate_nodejs application in the Server view and right-click
and click Update and Restart.
|.'_ Problems E Console E Properties 4l Servers 52

T*IBM Bluemix - binnes@uk.ibm.com - workshop - https://api.eu-gb.bluemix.net [Started, Republish]

#2 cloudant_boilerplate_nodsjs - Daployed [Started, Republish] > T
Start
Stop
%, Restart
¥ Remove =

Launch JavaScript Debugger
Show BRecent Logs

pdate and Resta
Push

31. After the application is restarted, test the application to ensure that the change is now
live.

After the project has been tested, the application can be deleted to release resources for
future exercises.

32.Right-click the project in the Explorer view and click Delete to delete the project. Delete

project contents on disk and then click OK.
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You are asked whether you want to delete the cloudantNoSQLDB service. Select the
checkbox to delete the service. In the Bluemix web Ul, confirm that the application and
server have been deleted.

Important: Deleting a project that is deployed through Eclipse also deletes it from Bluemix.
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